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Using Multi-Table Forms 1 

1 

One of the primary goals in designing a database is to reduce redundancy in entering 

data.  For example, not having to enter the customer’s information that resides in the 

Customers table again when entering a record for that customer in the Orders table.  

In a relational database there has to be some amount of redundant entries in order for 

two tables to be relatable.  At the very least the Orders table would have to contain a 

common field, such as Customer ID field, to the Customers table in order to relate the 

two tables together. 

However, even that redundant entry can be eliminated by creating a form that con-

tains multiple related tables.  Access can automatically fill in the common field in the 

related tables.  Only one screen would be necessary to complete a record from the 

Customer information, Order Summary information, and Order Details information.  

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

Reference query for form: qryCustOrderDetail  

Steps: 

 Create and Save a query with the related tables using 

all fields 

 Select the query in the Navigation Pane 

 Click the Create Tab, More Forms button 

 Click the Form Wizard command  

 In the first Form Wizard Box, move all fields to the right side, and click Next 

 In the next Form Wizard Box, select the Viewing Options that display the data 

by the Primary Table (i.e. tblCustomers), and click Next button 

 Choose the Layout for the Sub-Forms (i.e. Tabular), and click Next button 

 In the Style box, select preferred options (i.e. Apex), and click Next button 

 In the last Form Wizard Box, type a name for each object 

 The common prefix for a form is frm (i.e. frmCustOrder) 

 The common prefix for a sub-form is fsb (fsbCustOrderA) 

 Click Finish button 
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1 
Using Multi-Table Forms 

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

Move all fields to the 

right side, and click 

Next 

Make sure the 

preferred query is 

selected 
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1 
Using Multi-Table Forms 

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

Choose the Layout 

for the Sub-Forms 

(i.e. Tabular), and 

click Next button 

Select the Viewing 

Options that display 

the data by the 

Primary Table (i.e. 

tblCustomers), and 

click Next button 
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1 
Using Multi-Table Forms 

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

The common prefix for a 

form is frm  

(i.e. frmCustOrder) 

The common prefix for a 

sub-form is fsb  

(i.e. fsbCustOrderA) 

In the Style box, 

select preferred 

options (i.e. Apex), 

and click Next button 

Type a name for each 

object 

Click Finish button 
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1 
Using Multi-Table Forms 

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

Note Redundant Entries 
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1 
Using Multi-Table Forms 

REDUCING REDUNDANCY WITH MULTI-TABLE FORMS 

Combining the related tables into one form does not automatically reduce the 

redundant entry of the common related fields (i.e. Customer ID, Order Number).  

However, the common fields in the related tables (i.e. CustomerID from 

tblOrdersSummary, OrderNumber from tblOrderDetails) can be deleted.  Access will 

still fill them in automatically from the Primary table (i.e. tblCustomers, 

tblOrdersSummary). 

These fields from the related tables can be deleted in the Design View of the form. 

Steps To Remove Redundant Fields: 

 Change the form window to the Design View 

 Click into the Sub Form (i.e. tblOrdersSummary) 

 Select the common related field (i.e. CustomerID) 

 Press the Delete key on the keyboard <Del> 

 Repeat for secondary related tables  

 (i.e. OrderNumber from tblOrdersDetails sub-form) 

 View the results in the Form View or Layout View and Save the form 

NO Redundant Entries 
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2 Graphically Enhance Forms 

CUSTOMIZING FORMS GRAPHICALLY 

Reference form: frmFormGraphics 

Forms are the backbone of data entry in a database.  Effective forms are 

graphically enhanced to make data entry easier and simpler. 

Access provides a variety of methods to enhance forms graphically.  They include 

formatting options, sizing and alignment controls, and stacking order. 

UNDERSTANDING FORM CONTROLS 

Controls are graphic objects in Forms and Reports.  They include fields, text boxes, 

labels, and graphic pictures.  Controls can be moved, sized, and formatted.  There 

are three types of controls: 

Bound Controls These are elements like the fields that belong to the 

underlying table or query that the form is based on.  Any 

changes to the data in these fields automatically update the 

data in the report. 

Unbound Controls These include elements such as graphics, lines, text objects 

or other elements that do not belong to the underlying table 

or query.  For example, a title added to the report window. 

Calculated Controls These include calculated fields added to the report and are 

not part of the underlying table or query.  For example, 

adding a calculation on an inventory report that displays the 

total value of the inventory based on the price and  

quantity-on-hand fields. 

SELECTING CONTROLS 

You select controls by clicking on them with your mouse.  When you select a 

control, squares will appear around the control.  These squares are called 

“Handles”.  There are eight “handles” with one large handle (for moving) on 

the top left of the control selected. 

You can select multiple controls by using your Shift Key or by dragging a 

“Net” around them with your mouse. 
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2 
Graphically Enhance Forms 

Label Textbox 

Example of a Bound Control 

Example of UnBound Controls (Image and Label) Note: 

Small square “handles” 

represent which side of the 

control is selected and can 

be used to size the control 

Once you select a control you can move or size it.  You move a control by clicking 

over that control, and in the same motion, dragging it to a new location.  You will 

see the mouse shape change to a hand with all its fingers outstretched. 

You can move one side of the control (label or text box) 

by clicking on the large handle on the part of the 

control (you will see the mouse shape change to a hand 

pointing a finger) and dragging that to a new location. 

You can size a control by clicking on a small handle 

(you will see a double-headed arrow) and dragging to 

make that control larger or smaller. 

MOVING AND SIZING CONTROLS 

CUSTOMIZING FORMS GRAPHICALLY 

You can select multiple controls by using your Shift Key or by dragging a 

“Net” around them with your mouse. 
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Steps To Allow Customizing Of Controls In Form Design: 

 Change the form window to the Design View 

 Select all the label sides of the controls as one selection (Shift key or “Net” drag) 

 Click the Arrange Tab 

 Click the Group command, then immediately click the Ungroup command 

 Click away from the selected controls 

 Size and Move any control individually as needed 

 Save the form 

 View in Form View 

By default, Access 2007 selects both the textbox and the label parts of the control.  

That means, if one side of the control is moved or sized, the other is as well.  The 

controls can be separated by selecting the labels of all the controls at the 

same time and then clicking the Group command followed by clicking the 

Ungroup command on the Arrange tab. 

You can select multiple controls by using your Shift Key or by dragging a “Net” 

around them with your mouse. 

Selected label controls 

on a 

form 

Note: 

Heavier border 

represents which 

side of the control 

will be changed if 

a format is applied 

UNGROUPING FORM CONTROLS TO ALLOW SIZE AND MOVE OPTIONS 

2 
Graphically Enhance Forms 

Reference form: frmFormGraphics 
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2 
Graphically Enhance Forms 

FORM DESIGN RIBBON COMMANDS 

There are two ribbon command sets in Form Design.  The Design Tab and the 

Arrange Tab.  The Design Tab includes commands to format fonts, add logos and 

dates to forms automatically, add controls for calculations and text, formatting 

options for fill colors and line styles.  The Arrange Tab includes commands for 

managing alignment, auto–sizing, and arranging stacked controls.  Some of the 

commands on the Arrange Ribbon require two or more controls to be selected (i.e. 

alignment, size, and position commands). 

Design Tab on the Form Designs Tools Area of Design View 

Arrange Tab on the Form Designs Tools Area of Design View 
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ALIGNING AND SIZING CONTROLS 

2 
Graphically Enhance Forms 

Reference form: frmFormGraphics 

Steps To Aligning And Sizing Controls In Form Design: 

 Change the form window to the Design View 

 Select all the preferred controls as one selection (Shift key or “Net” drag) 

 Click the Arrange Tab 

 To Align controls, click the appropriate command in Control Alignment group 

 To Size controls, click the appropriate command in Size group 

 Save the form 

 View in Form View 

Before - Aligning and Sizing Controls 

After - Aligning and Sizing Controls 

Controls are aligned to the 

left control and sized to 

widest 

Before - Aligning and Sizing Controls 
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2 
Graphically Enhance Forms 

SPACING AND STACKING CONTROLS 

Steps To Spacing And Stacking Controls In Form Design: 

 Change the form window to the Design View 

 Select all the preferred controls as one selection (Shift key or “Net” drag) 

 Click the Arrange Tab 

 To Space controls, click Horizontal or Vertical Spacing in Position group 

 To Stack controls, click Bring to Front or Send To Back in Position group 

 Save the form 

 View in Form View 

Before - Spacing Controls Before - Stacking Controls 

After - Spacing Controls After - Stacking Controls  

(Rectangle was Sent To Back) 
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FORMATTING CONTROLS 

2 
Graphically Enhance Forms 

Reference form: frmFormGraphics 

Steps To Format Controls In Form Design: 

 Change the form window to the Design View 

 Select all the preferred controls as one selection (Shift key or “Net” drag) 

 Click the Design Tab 

 To Format controls, click the appropriate command in Font group 

 To Conditionally Format controls, click the Conditional command 

 Create Rule 

 Set Formatting 

 Click OK 

 Save the form 

 View in Form View 
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2 
Graphically Enhance Forms 

ADDING GRAPHIC CONTROLS TO A FORM 

Steps To Add Graphic Controls In Form Design: 

 Change the form window to the Design View 

 Click the appropriate tool in the Controls Group 

 Click on the form where the control will be placed 

 Follow any instructions or dialog boxes, if necessary 

 To Format controls, click the appropriate command in Font group 

 Save the form 

 View in Form View 

Graphic controls that can be added to forms include ones to create text, add logos 

and other images to the form, and draw shapes (i.e. rectangle or line tools) 

Line Tool 

Rectangle Tool 
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3 Adding Non-Keystroke Entry Controls 

REDUCING DATA ENTRY ERRORS WITH GRAPHIC CONTROLS 

Reference form: frmDataEntryControls 

Efficient and precise data entry is the key to accurate queries and reports.  Forms 

with graphic entry controls can drastically reduce many errors created by key 

stroking the data.  Graphic data entry controls include combo boxes, list boxes, and 

option groups.  The Control Wizard tool provides a series of dialog boxes from 

which to build these types of controls. 

Steps To Add Non-Keystroke Entry Controls In Form Design: 

 Delete the original control on the form in Design View 

 Make sure the Use Control Wizards command is on 

 Click the appropriate tool in the Controls Group (i.e. Combo Box) 

 Click on the form where the control will be placed 

 Follow any instructions or dialog boxes, if necessary 

 To Format controls, click the 

appropriate command in Font 

group 

Before Converting Territory Field To A Combo Box After Converting Territory Field To A Combo Box 
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3 
Adding Non-Keystroke Entry Controls 

CREATING A COMBO BOX LIST IN A FORM 

Choose how the combo 

box list will be built. 

 

If there is an underlying 

table that contains the 

list data choose the first 

option… 

“ I want the combo 

box to look up the 

values in a table or 

query” 

Select the underlying 

table or query that 

contains the data for the 

combo box list. 
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3 
Adding Non-Keystroke Entry Controls 

CREATING A COMBO BOX LIST IN A FORM 

Select the fields that will 

display in the combo box 

list.  That can be one or 

more fields (i.e. Product 

Code and Description) 

Choose if the field will be 

sorted ascending or 

descending order 
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3 
Adding Non-Keystroke Entry Controls 

CREATING A COMBO BOX LIST IN A FORM 

Use this dialog box to 

adjust the column width 

so that all entries will 

show completely in the 

list. 

 

Note: If one of the fields 

chosen is the primary 

key of the underlying 

table then that field will 

need to un-hidden in this 

box.  A checkbox would 

be available to do that. 

Choose which field will 

be used to store the 

data as it is selected. 

 

If the combo box list will 

be used in conjunction 

with a macro (not for 

data entry) to perform 

another action then 

select “Remember the 

value for later use”. 
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3 
Adding Non-Keystroke Entry Controls 

CREATING A COMBO BOX LIST IN A FORM 

Type a label for the combo 

box list field.  This is 

equivalent to a caption. 

Completed combo box 

list in the Form View 
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3 
Adding Non-Keystroke Entry Controls 

CREATING AN OPTIONS GROUP IN A FORM 

Type the entries for the 

Option Group list in the 

order the entries should 

appear. 

 

Note: 

Use the Down Arrow key 

to move to the next cell 

down and not the Enter 

key or Access will just take 

you to the next dialog box. 

Choose whether a 

default value will be  

pre-selected. 

Use Down 

Arrow key 

to move to 

next cell 

down! 

An Option Group in a form is a graphical method to 

choose from a open area of options.  Only one value 

can be chosen within an Option Group. 

Reference form: frmDataEntryControls 
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Accept the values as 

they appear here. 

These are internal 

values based on the 

order of appearance in 

the Options Group. 

Choose which field 

will be used to store 

the data as it is 

selected. 

 

If the combo box 

list will be used in 

conjunction with a 

macro (not for data 

entry) to perform 

another action then 

select “Remember 

the value for later 

use”. 

3 
Adding Non-Keystroke Entry Controls 

CREATING AN OPTIONS GROUP IN A FORM 
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Choose the type of 

graphic entry preferred.  

(Option buttons, Check 

boxes, Toggle buttons) 

Which ever option that is 

chosen does not effect 

how many values can be 

chosen since within an 

Option Group only one 

value can be chosen. 

 

Choose a preferred style 

for the display of the 

Options Group. 

Type a label for the combo 

box list field.  This is 

equivalent to a caption. 

3 
Adding Non-Keystroke Entry Controls 

CREATING AN OPTIONS GROUP IN A FORM 
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4 Creating A List To Find Records  

USING A COMBO BOX AS A SEARCH TOOL IN A FORM 

As mentioned in the previous chapter, a combo box is an effective method to 

minimize key stroking and thus preventing possible errors during data entry.  In 

addition to using a combo box as a data entry tool in a form, it can also be used as 

a search tool.  For this tool to search efficiently, a unique entry field such as the 

primary key field (i.e. CustomerID field in the Customers table) within that form’s 

records needs to be used as the primary search criteria.  Other fields (i.e. Customer 

Name) can be displayed in the combo box list as a help to select the correct value. 

Consider using a Combo Box as a search tool in a Customers table in which the of 

the CustomerID field (and perhaps the Customer Name) is used in a combo box to 

locate customers by selecting one in that list. 

Using A Combo Box As A Search Tool In Form Design: 

 View the form in Design View 

 Make sure the Use Control Wizards command is on 

 Click the Combo Box tool in the Controls Group 

 Click on the form where the control will be placed 

 Follow instructions in subsequent dialog boxes (following pages) 

 To Format controls, click the appropriate command in Font group 

 Save the form 

 View in Form View 

 Select a value from the list to verify that it navigates to that record 

Reference form: frmDataEntryControls 
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4 
Adding Non-Keystroke Entry Controls 

USING A COMBO BOX AS A SEARCH TOOL IN A FORM 

Choose the option… 

“Find a record…” 

to let Access know that 

you want to use this 

Combo Box as a search 

tool. 

Choose the fields 

that will display in 

the list.  Remember 

that a unique field 

such as a Primary 

Key field needs to 

be used otherwise 

the tool will not be 

as efficient and 

make it harder to 

find the correct 

record. 
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4 
Creating A List To Find Records  

USING A COMBO BOX AS A SEARCH TOOL IN A FORM 

If one of the fields 

chosen is the primary 

key of the underlying 

table then that field will 

need to un-hidden in 

this box. 

 

Use this dialog box to 

adjust the column 

width so that all entries 

will show completely in 

the list. 

 

 

Type a label for this 

field.  This is the 

equivalent of a 

caption property. 

Uncheck To See Customer ID Field! 
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4 
Creating A List To Find Records  

USING A COMBO BOX AS A SEARCH TOOL IN A FORM 

Combo Box On A Form Used As A Search Tool 


